Hello all,

 

I am using a RoboVero board mounted on Overo. I tried to talk to the boards using the example Python scripts.

 

When I try to run IMU.py, the command line just hang there and I cannot even kill the program. On the RoboVero board, the LED heartbeat stop flashing once I run the script. To restore control, I need to restart the RoboVero board and the connection.

 

After a closer look into IMU.py, I found that problem is caused by this function:

I2C_MasterTransferData()

 

which is called when the program wants to write/read register values (writeReg/readReg). Since accessing the sensors (accelerometer, compass, gyro) needs to go through this procedure, the program halts.

 

I tried connecting through USB and SSH. For adc.py, callback.py and DSP.py, they work as expected (turning the LED on/off by pushing button, reading adc values, etc). I believe I have configured the boards correctly, but there should be some issues within the I2C routine.

 

Can anyone shed a light on the problem? Does anyone experience similar problem? How can I look into the I2C problem?

Any help would be appreciated.

 

Many thanks,

Thomas